Forum How do I...?

Unix error msg

I ran Prince successfully on WinXP with an XHTML file and a corresponding style sheet.

On Fedora Core 3 Linux, I run prince and get this:

yurta{root}119: /usr/local/bin/prince -s 1500_nopage.css 1500_new.xml test.pdf
prince: warning: no glyphs for character U+0054
prince: internal error: no fallback glyph for character U+0054

What do I do to fix this? My charset is set to iso-8859-1. Do I have some character in my file that I brought over from Win XP that is illegal?



:?: :?: [/code]
It was a matter of installing MSTTCoreFonts for my RH Linux as detailed in your Documentation FAQ.

The installation went quite painlessly! :P


Today I installed Debian and downloaded Prince. After installing the required packages I tried to run Prince as on Windows (first time Linux). After searching the docs I saw that I could call Prince from the command-line. I did like this:

debian:/usr/lib/prince/bin# prince /home/martin/test.html

The file, test.html, looks like this:

<p>lorem ipsum dolor...</p>

The pdf generated just contains of the first page though, the one saying that this file is generated by Prince etc.

Please tell me what I did wrong.

Edited by martin

Ahum.. it seems like the pdf viewer on Debian don't behave exactly like Adobe Acrobat. Instead of scrolling down, you have to locate a button at the top panel, to view the next page.

Ok. That's about it from me this time. :oops:
Just for the sake of clarity, there is no GUI for Linux (Debian), right?
Hi martin,

martin wrote:
Just for the sake of clarity, there is no GUI for Linux (Debian), right?

Right, there is no GUI for Prince on Linux or MacOS X at this time.

If we made a GUI for Linux it would probably have to be a gtk+/GNOME program using xpdf for previewing the PDF output. However, it would be quite a large undertaking to develop such a GUI, and it is competing for our time with lots of other feature requests. One day perhaps! :)

Best regards,