Forum How do I...?

Problem to execute prince

hi friends,
I logged in as root and have successfully installed prince in unix environment ... :)
set the path 4 prince exe
but when tried to run it me error
" ksh: prince : not found" :cry:

waiting 4 ur valuable replies..
Please do neeful.
Clearly the PATH is not correct. Can you run Prince by using the full path, eg. /usr/bin/prince, or wherever you installed it?
thanks mike but
I had installed prince in system direcory /usr/local/bin/prince
I tried with full path but still it is giving same error...
Is their any other step we need to do after running script?
Can you check that there is a valid shell script at /usr/local/bin/prince and an executable binary file at /usr/local/lib/prince/bin/prince? Try running each one from the terminal, eg.
$ ls -l /usr/local/bin/prince
$ /usr/local/bin/prince
Please see the code 4 more details...

root:/$>ls -ltr /usr/local/lib/prince/bin/prince
-rwxr-xr-x   1 bin      bin      9431348 Jul 14 14:47 /usr/local/lib/prince/bin/
root:/$>ls -ltr /usr/local/bin/prince
-rwxr-xr-x   1 bin      bin           88 Jul 14 14:47 /usr/local/bin/prince
/usr/local/bin/prince: /usr/local/lib/prince/bin/prince: cannot execute
root:/$>vi /usr/local/bin/prince

#! /bin/sh

exec /usr/local/lib/prince/bin/prince --prefix="/usr/local/lib/prince" "$@"

ksh: prince:  not found

The "cannot execute" is the problem. Which package did you install and what operating system and hardware are you running on?
I had connected to the remote server by Telnet service.
Done the FTP of setup and ran script.
After giving successfull installlation msg i tried to run and encountered with this error.
Is any package is required to run prince ?
Is it your server? Is it Linux? Solaris? FreeBSD? Can you run "uname -a"?
It is client server running with SunOS (Sun-solaris - 10)
Intel (x86) or Sparc? It sounds like the wrong Prince package was installed, there are two available for Solaris 10, can you try installing the other one?
Thanks buddy.....
The sparc package is working.
I have the same issue but running it with Laravel on Mac OSX 10.14.2

I can execute the prince executable just fine:

Noahs-MacBook-Pro:~ noahgary$ /usr/local/bin/prince --version
Prince 12.4
Copyright 2002-2018 YesLogic Pty. Ltd.
Non-commercial License

But I get:

Prince error: 1: prince: not found Prince.php 229
Okay. So the problem ended up being docker. Can't find the local file on my mac when I'm running in a container ¯\_(ツ)_/¯

I found a workaround so no need for an answer anymore.