Forum How do I...?

Silent Installation on Windows


I am planning on using Prince on Windows Azure. The way the cloud service works is that any files/software installed will be removed when the service is restarted. They have a workaround that allows me to install it via startup task, but I need a way to do this via a command-line installation of Prince.

Is there a way to do this?

If you are calling Prince from the command-line or via the Java/.NET/PHP interfaces, you can install it by copying the contents of the Prince\Engine folder. Prince does not modify any system settings or install any new system libraries, so this is all that is required.
Great. That is what I was thinking. Thanks!
Sorry to resurrect an old thread, but is this still the recommended way to script a Prince install in version 10?
We have a Windows package available as a ZIP file now, so there is no need to run the installer if you would prefer to script it in other ways.
I just tried installing Prince on Azure, it was quite easy. After creating the account, I chose to use the "Ubuntu 18.04" virtual machine (VM). Then I found the IP address and was able to SSH into the VM. Once inside, I ran these commands:
howcome@princevm:~$ wget
howcome@princevm:~$ mkdir prince
howcome@princevm:~$ cd prince
howcome@princevm:~$ tar xvzf ../prince-12.3-linux-generic-x86_64.tar.gz 
howcome@princevm:~$ cd prince-12.3-linux-generic-x86_64/
howcome@princevm:~$ sudo ./ 
howcome@princevm:~$ sudo apt-get install fontconfig
howcome@princevm:~$ sudo apt-get install libgomp1
howcome@princevm:~$ prince -o foo.pdf

On day 2, I tried installing the Debian package:

howcome@princevm:~$ wget
howcome@princevm:~$ sudo dpkg -i prince_12.3-1_ubuntu18.04_amd64.deb

This resulted in some dependency problems:

dpkg: dependency problems prevent configuration of prince:
 prince depends on libgif7 (>= 5.1); however:
  Package libgif7 is not installed.
 prince depends on libjpeg8 (>= 8c); however:
  Package libjpeg8 is not installed.
 prince depends on liblcms2-2 (>= 2.7); however:
  Package liblcms2-2 is not installed.
 prince depends on libpixman-1-0 (>= 0.30.0); however:
  Package libpixman-1-0 is not installed.
 prince depends on libtiff5 (>= 4.0.3); however:
  Package libtiff5 is not installed.

To fix this, I ran:

howcome@princevm:~$ sudo apt --fix-broken install

Edited by howcome