Forum Bugs

Crashes with Mercury Runtime bus error on Intel MacPro

Chris Thorman

I have successfully used prince on Mac G4, Mac G5, and Linux.

On my new intel-based macPro (64-bit quad Xeon), it does this:

./prince/lib/prince/bin/prince ./prince/examples/magic.xml ~Desktop/magic.pdf

*** Mercury runtime: caught strange bus error ***

I tried this with both r9, and the latest, r11, with the same results.

I haven't tried it on a 32-bit Intel Mac (e.g MacBook) yet, but could if this would help.

Hi Chris,

The MacOS X version of Prince is for PowerPC Macs, so it is presumably running under emulation on Intel Macs if it runs at all. We have had reports of it running successfully, but slowly, on 32-bit Intel Macs; perhaps you could confirm that?

It seems that we will need an Intel build or a universal binary to properly support Intel Macs for a future release of Prince.

Best regards,

Chris Thorman

Yes, I can confirm it does run on 32-bit mac Intel (yes, very slowly, under Rosetta emulation).

Not sure why it would not run under the 64-bit system; generally emulated PPC programs run just fine.

I haven't built a universal binary myself, but if I understand correctly, it's not much more than a switch in the development tool -- the switch enables cross-compilation for both architectures, and the result is a binary file with code segments for both.

I don't think you'll need to create a 64-bit compile; the 32-bit "universal" binary should run fine on the 64-bit chips.

I just attempted to use prince on a 32-bit MacBook Pro and received the same error. Any solutions found?
Currently Prince only supports MacOS X running on PowerPC based hardware, but we are investigating building a universal binary for a future release of Prince that will also support x86 based hardware.
We have now released Prince 6.0 rev 3, which includes a MacOS X package with a universal binary that should run without errors on Intel Macs.