Forum How do I...?

Font selection question

I'm currently using prince Prince 5.0-beta3 (although it reports its version as beta2) on os x. I'm trying to use Futura medium, a true type dfont that comes with osx.

It is tricky to get this font to display with some level of constancy. For web browsers I list 'Futura Medium', Futura-Medium, Futura in my css. Prince picks up the last one and then for some reason uses italic. When I use --verbose I get:
prince: used font: Futura, Medium Italic

So finally the question, Why is prince using Medium Italic instead of just medium, and then how do I get it to use medium?

Thanks for reporting the issue with the Futura font, we will investigate this and see what is going wrong.

I'm currently using prince Prince 5.0-beta3 (although it reports its version as beta2) on os x.

That is strange; could you please verify that you are using the following link to download beta 3: and then try running:

prince --version --debug

and post the results here? It should say beta3, not beta2.
Hi Just followed your link ran the installer and prince --version --debug produces:
prince: debug: loading license: /usr/local/lib/prince/license/license.dat
YesLogic Prince 5.0-beta2
Copyright 2002-2005 YesLogic Pty. Ltd.
Demo License
build-date: 2005-06-26
build-compiler: mercury-rotd-2005-01-11
build-grade: hlc.gc
build-libxml: 2.6.19

Hope this helps

Thanks for the Prompt response.
That is really very strange, as when I try the same thing here it comes up as beta3. Perhaps you have an old version of beta2 in your path somewhere, that is getting called when you run prince?
Unfortunately When I select futura medium in the font book It comes up bold, not italic so I don't think that has a bearing, nice idea though.

Ok finally figured out the problem with the installer, I need to cd into the same directory as the shell script befor I run it, Otherwise the installer makes the directory structure but can't fined the install files. Since I was upgrading the upgrade never happened, oops.All fixed now.

Still not getting futura medium though.
I have created a test version of Prince that should use the correct Futura fonts, it is available for download here:

Please give it a try and let me know how it goes :)
Thanks for being so prompt, but, No progress I'm afraid. Is there any info about my system that would help solve the problem?


I know this is going to sound strange, I was working on another aspect of the css and this problem has gone mysteriously away. I don't know why but now it is working correctly. Does prince use some sort of caching?

Excellent, I'm glad to hear that it works correctly now -- although I've got no idea what caused the delayed reaction you describe :D