Forum How do I...?

Turning off ligatures

mn4367
I learned that Prince uses ligatures by default. But how do I turn this off? I saw that
font-variant: prince-opentype();

prevents ligatures in the output, but is that syntactically correct?
mikeday
Does that actually work? I would have thought it doesn't, as you are not specifying any OpenType features to apply.
mn4367
Hmm, you're right, that doesn't work, I must have checked the wrong output, sorry. But the question is still how to to turn this off. I could do something like this.
font-variant: prince-opentype(xyz);
or
font-variant: prince-opentype(noliga);

That works (and Prince log any errors) but it is certainly not the "correct" way?
mikeday
Yes, either of those will work. Currently there is no official way to turn off ligatures; if you try to apply an empty set of OpenType substitutions, then Prince will apply the default set, including liga.
mn4367
Ok. I think I'll use noliga, this expresses the intent in an understandable way.
Thanks!