Forum Bugs

Docker - Dependency is not satisfiable: libssl1.0.2 (>= 1.0.2d)

I've had the attached Dockerfile running for a while. All of a sudden when I try to run it, I am getting the following error

Dependency is not satisfiable: libssl1.0.2 (>= 1.0.2d)

Here are the logs around that error

Step 5/23 : RUN curl -O
---> Running in 70a98daf222c
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 5031k 100 5031k 0 0 1348k 0 0:00:03 0:00:03 --:--:-- 1348k
Removing intermediate container 70a98daf222c
---> 7f208f40e81c
Step 6/23 : RUN echo 'y' | sudo gdebi prince_12.2-1_debian9.1_amd64.deb
---> Running in b1c01919c00f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done
This package is uninstallable
Dependency is not satisfiable: libssl1.0.2 (>= 1.0.2d)

ERROR: Service 'pdf' failed to build: The command '/bin/sh -c echo 'y' | sudo gdebi prince_12.2-1_debian9.1_amd64.deb' returned a non-zero code: 1

I do realise this is an older version of Prince. I have tried the latest version also and I get the same result. Any idea where that dependency comes from?

The issue seems to be on fresh MacOS installs. If I do a no cache rebuild of the container on a machine that already had it running on, it installs fine.
  1. Dockerfile1.9 kB
  2. Logs.rtf70.9 kB
It seems php:7.2-apache is based on Debian 10 (buster) now. You can use the Prince 12.5.1 package for Debian 10, or change your Docker image to run on Debian 9 (stretch).
Great pickup! Thank you, I obviously just needed some fresh eyes. I've updated the php package to `php:7.3-apache-buster`

For those interested, attached is the new Dockerfile
  1. Dockerfile1.9 kB
We have made Docker images available for Prince here:

Which can be used as described in the documentation: