Forum How do I...?

Prince Logo Watermark with paid license

We have an installation of the prince software on a on-prem VM server. Version 9.0 rev 5, professional license. It worked fine there. A month and a half ago that server was imaged and imported to AWS. During this process the name of the server changed and of course the IP changed.
Now we are getting the prince logo watermark on the pdf's. When I check the license of Prince, it shows as active.
My guess here is that the license and/or software needs to be reinstalled. As I am unfamiliar with the software I thought I would post here for a more knowledgeable opinion before I did anything. This is a production server.
Will just a license install fix the issue or will I need a complete reinstall of the software and license?
Thanks in advance for any assistance.
Installing the license should be fine, then run "prince --show-license" to confirm. If you wish to upgrade to a newer version of Prince you may need to purchase a support contract.

However please note that the Professional/Desktop license is for interactive use by a single user, not for server use.
I'm very new to this and have a similar issue.
A paid licence with version 10r4. Installation on a new MacBook using Big Sur has gone fine but its not finding the license file. Has the directory of the usr folder changed?
The kick back from terminal is;

jimmy.atter@Jimmys-MBP ~ % prince --show-license
prince: /usr/local/lib/prince/license/license.dat: error: can't open input file: Not a directory
prince: warning: failed to load external entity "/usr/local/lib/prince/license/license.dat"
prince: /usr/local/lib/prince/license/license.dat: error: could not load license

Where am I going wrong?
Where is Prince installed exactly? Did you run the install script?
These are the instructions I've been left, so I would assume the its default location from the installer;

a. Unzip prince-10r4-macosx.tar

b. Run the installer: sudo /Users/matt/Projects/productbuilder/__install/prince-9.0r5-macosx/

c. Copy the license.dat file to ‘/usr/local/lib/prince’ by;
sudo cp ~/Desktop/license.dat /usr/local/lib/prince/license

I have never had to use the install script before on previous OS's.

That seems reasonable other than the versions not matching in steps a and b.

Can you check if /usr/local/lib/prince/license/license.dat actually exists?
Sorry 'b.' hadn't been updated to match 'a.'

I've ran the find / command in terminal and its only found the license.dat file on my desktop.
The only 'usr' folder I can find is now in 'System/iOSSupport/' folder but that's not what I'm after. So no, it doesn't look like it exists.

the --show-license command throws up the same error as my first post.
I've just tried installing Prince again and found 'install: /usr/local/lib/prince/license exists but is not a directory'
But then follows that with an installation complete message.

Install directory
This is the directory in which Prince 10r4 will be installed.
Press Enter to accept the default directory or enter an alternative.
-n [/usr/local]:

Installing Prince 10r4...
Creating directories...
install: /usr/local/lib/prince/license exists but is not a directory
Installing files...

Installation complete.
Thank you for choosing Prince 10r4, we hope you find it useful.
Please visit for updates and development news.
Perhaps there is an existing file called "license" in that location where there should be a directory? If so you can remove it and rerun the install and it should work.
Thanks Mike. I ran the command 'rm -i /usr/local/lib/prince/license'

Reinstalled Prince and copied the license file. We are now up and running without a watermark.

Thanks for your help.
Hey Mike,

Thanks for the help. Reinstalling the license worked for me. Sorry for the late reply.