Forum Bugs

Fatal error running Prince6.0 rev5 on Win2K

I just installed Prince 6.0 rev 5 on my Win2K computer.
When I try to convert via the GUI I get an error "Unknown data read from pipe", and the document isn't converted.
From the command line I get:
"Mercury runtime: cannot set SIGSEGV handler: Invalid argument"
I get this error message even for the command "prince --help".

After I installed prince 5.1 rev3 and it works fine.

Any ideas?

Prince 6.0 is using a newer version of the Mercury compiler and runtime, so perhaps there is an incompatibility with Windows 2000. We'll try to track down the problem. In the meantime, Prince should run fine on XP, Vista, Linux or MacOS X. :)
Hi there!

I'm evaluating the product. Any info on when the bug will be solved?

We've experienced the same, installing Prince 6 at a client site, similarly on Windows 2000. [Though I'm pretty we've had other Win2000 installations that have been OK].

Is there any update on this bug, or ideas when it might be solved?

(Running 5.0 at that particular client is OK, but obviously does limit us from using some of the nicer bits of the new version)
We are making progress on this issue, it seems to be caused by the libraries we are using for HTTP and HTTPS support in Prince. We are currently attempting to find a better solution for the problem than disabling these libraries altogether.
We've narrowed the problem down to the SSL support required for HTTPS, and created a new build of Prince 6.0 rev 6 in which SSL has been disabled, available here:


This build should work fine on Windows 2000, but will fail to retrieve content from HTTPS URLs. Hopefully this is an acceptable compromise. :)
One of my colleagues is at our Win 2K client today, and tried to install the special non-ssl version. Sadly, we are still getting an error.

The GUI gives "unknown data read from pipe"

The CLI gives "Mercury Runtime: cannot set SIGSEGV handler - invalid argument"

That's running against any file, including the ones in the example directory (so it's not HTTPS requests or anything like that). The Machine is Win 2000 (probably server) SP3.

V5.1 installs OK but we can't use it because it only accepts local files for CSS and not HTTP urls.

If you need any more info to help the debug process, I'm afraid you need to ask in the next few hours, whilst he is onsite.

Darn, disabling SSL fixed the problem on our Windows 2000 installation here, and I can't reproduce the problem without it. I suppose upgrading to XP is out of the question? Win2k is eight years old now... :)
Upgrade? LOL. This is a UK Government department we are talking about. They have probably only just upgraded to Win 2K. I will ask what their plans are.
Good point, and now that XP is passing over the horizon the choice of sticking with 2000 or upgrading to Vista is painful to contemplate. :)