Forum Bugs

remote loading of hyphenation dictionaries fails.


I'm trying to use an openoffice dictionary for hyphenation. I have a repository on a server, which contains all the files. Trying from the local machine (Mac OS X Leopard), I get the an error.
Double Post

Edited by oliof

(2nd post to get by 'no links on first post restriction'):


prince -o tsoy-a5.pdf

prince: error: can't open input file: No such file or directory

I didn't obscure the URL so you can see it's accessible.

Running prince locally on the server (linux amd64) gives the same error.

If I run it locally on the server reference the html file to convert directly, I get no errors (in $WEBROOT/schatten/: prince -o tsoy-a5.pdf tsoy.html).

Here's my hyphenation definition from the css file:

prince-hyphenate-patterns: url("hyphenation/hyph_de_DE.dic") ;
hyphens: auto ;
prince-hyphenate-before: 2;
prince-hyphenate-after: 3;

I run prince 6.0 rev 6 on both ends.

if I change pricne-hyphenate-patterns to url(""),running prince agains the local file fails, too.

Is this expected behavior?
At the moment there is a limitation of Prince that hyphenation dictionaries must be local files. We will remove this limitation in a future release.
The latest builds now support loading hyphenation dictionaries from HTTP URLs, sorry it took so long. :)