Forum How do I...?

Can I make use of otf fonts?

Quick question. After reviewing the information, it would seem they are not supported, but maybe it is only partially? Can I link to otf fonts at all?

And while I'm at it, is there support for kerning?
Prince does not support OpenType fonts with PostScript CFF outlines (.otf files). We do plan to add support for these fonts in Prince 7.0, which will also support kerning.
Sorry to be annoying, but any idea how long till Prince 7 is likely to be available? Postscript font support would make my life a lot easier since I'm currently faced with purchasing TTF versions of typefaces I already own.
We will be releasing a beta version of Prince 7.0 soon, in the meantime there are early packages available with support for .otf fonts:

Thanks very much! I'll try them out today.
I will test this over the weekend and come back with results.

For anybody who is resistant to test early releases, FontForge is a free font creation tool that can also convert from OTF to TrueType.

Does this Release support OTF fonts with PostScript Outlines?

Update: It does support OTF fonts with PostScript Outlines. Yay! Now I need to find out why the fonts I use don't work in the real project I have where as they work in a reduced case.
I keep replying to myself:

I manage to get invalid output with 7a20 on a Mac by adding certain glyphs to the text I want to convert (i.e., ∞). Want to have a test case for that?
Yes, we love test cases. :)
carl johnson
The alpha doesn't seem to work with the free OTF fonts Museo and Museo Sans. :(
We were just testing with Museo and were able to get some output, which platform are you running Prince on and what errors are you getting?
carl johnson
I'm on OS X. There's no error message, it just leaves a blank spot where the text should be. If I try to highlight it where the text should be, it doesn't select anything and nothing from it copies into the clipboard. I ran prince with the --verbose option, and here's all it said:

[me@MacBook:~]$ prince ~/Desktop/test.html --verbose
prince: loading XML input: /Users/me/Desktop/test.html
prince: used font: Museo, 500
prince: used font: Times New Roman, Regular

The test file was a bare bones XHTML file with the first paragraph styled to use Museo and the others left unstyled.
I worked around this by specifying all font-* attributes in the CSS. Helped make Museo 300 and Museo 700 visible, but I could copy/paste fine before.
Hi Carl,

Would you be able to email me ( your test file, including the PDF? We've been having some issues with this font but they're not always reproducible, and it would be nice to track it down.

Best regards,

Test case is in your mailbox (-:
Thanks for the test cases, we have fixed a bug affecting the embedding of OTF fonts on MacOS X and there is a new build available here: prince-7.0a21-macosx.tar.gz
I'm just testing this –

In my test case, Museo 300 is replaced by Museo 700, other than that it works fine (easily discernable running prince in debug mode). Text shows, that is a plus.

In my real project, characters are replaced by the "no glyph" box with an X. I'll try to come up with a sample for that, too.
We have now released the first beta for Prince 7.0, which should hopefully fix these font issues.