Forum How do I...?

Mac OS 64-bit installation

I ran into the same error as this guy ( while installing prince on a mac os 64-bit machine. This guy resolved the issue by using a installer for a 64-bit version OS... but when I try to replicate his solution, I notice there's only 1 installer for macs. Does anyone know where to find the 64-bit installer if it even exists, or how to solve this problem?
If you are installing Prince in a system directory like /usr/local you will need to run the install script as the root user, for example with sudo like this:
sudo ./
I had installed prince using this command:

sudo bash

While using the command you suggested, I received this error:
sudo: ./ command not found

I am still experiencing this issue.
Which directory are you in? Is the file there?
Yes, I am in prince-11-macosx.

I got this message after running the file, so I think I did it correctly...

Prince 11

Install directory
    This is the directory in which Prince 11 will be installed.
    Press Enter to accept the default directory or enter an alternative.

Installing Prince 11...
Creating directories...
Installing files...

Installation complete.
    Thank you for choosing Prince 11, we hope you find it useful.
    Please visit for updates and development news.
Right that looks fine. What output do you get afterwards if you run "prince --version"?
$ prince --version
/usr/local/bin/prince: line 3: /usr/local/lib/prince/bin/prince: Permission denied
/usr/local/bin/prince: line 3: exec: /usr/local/lib/prince/bin/prince: cannot execute: Undefined error: 0

Same if I run
sudo prince --version

Edited by tphamwgsn

What kind of Mac are you running on? Does it have an Intel cpu?
Hardware overview:
Model Name: Mac mini
Model Identifier: Macmini3,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2.53 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache: 3 MB
Memory: 4 GB
Bus Speed: 1.07 GHz

Edited by tphamwgsn

That looks good. Which version of MacOS X is installed? What do you get if you run these commands:
file /usr/local/lib/prince/bin/prince
ls -l /usr/local/lib/prince/bin/prince
System Software Overview:
System Version: OS X 10.10.5 (14F2109)
Kernel Version: Darwin 14.5.0

$ file /usr/local/lib/prince/bin/prince
/usr/local/lib/prince/bin/prince: Mach-O 64-bit executable x86_64

$ ls -l /usr/local/lib/prince/bin/prince
-rw-r--r--  1 root  wheel  14096480 Jan 17 17:04 /usr/local/lib/prince/bin/prince
Ah the binary lacks execute permission, please try:
chmod a+x /usr/local/lib/prince/bin/prince

We will have to check the install script.
Sweet, that fixed the problem! Also glad that I may have a found a minor problem for you guys. Thanks a lot!!
Thanks for being patient. :)